Propagating EIGRP Default Route

Written on by admin on. Posted in EIGRP

With the use of default routes a better network performance could be achieved. For example routers at the access layer don’t need to know all routes in whole network. By using a default route you can significantly reduce the size of router’s routing table thus improving performance. There are few ways to propagate a default route into EIGRP domain, read further to see them …

  • Redistributed default route
  • Default route by using ip default-network command
  • Default route with network 0.0.0.0 command
  • By using ip summary-address command

Here is the topology used in this lab

 EIGRP-Default-Route

Before we begin configuration of default route injection, I will provide basic configuration for this lab

ISP

ISP(config)#interface fastEthernet 0/0
ISP(config-if)#ip address 10.0.0.1 255.255.255.0
ISP(config-if)#no shutdown 
ISP(config-if)#interface lo 0
ISP(config-if)#ip address 192.168.100.1 255.255.255.0

ISP(config)#ip route 192.168.0.0 255.255.255.0 fastEthernet 0/0

BORDER

BORDER(config)#interface fa0/0
BORDER(config-if)#ip address 192.168.0.3 255.255.255.0
BORDER(config-if)#no shutdown 
BORDER(config-if)#interface fa0/1
BORDER(config-if)#ip address 10.0.0.2 255.255.255.0
BORDER(config-if)#no shutdown

BORDER(config)#router eigrp 1
BORDER(config-router)#network 192.168.0.0 255.255.255.0

R1

R1(config)#interface fa0/0
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#no shutdown

R1(config)#router eigrp 1
R1(config-router)#network 192.168.0.0 255.255.255.0

R2

R1(config)#interface fa0/0
R1(config-if)#ip address 192.168.0.2 255.255.255.0
R1(config-if)#no shutdown

R1(config)#router eigrp 1
R1(config-router)#network 192.168.0.0 255.255.255.0

From picture you can see that default route injection will be made by BORDER router and will send all unknown traffic to ISP router, that’s why I have put a static route on ISP toward BORDER for 192.168.0.0/24 network, just for test purposes. Now, let’s proceed to configuration !

Redistributed default route

To redistribute a default route into EIGRP, we need to have one. I used a static default route on BORDER which points to ISP.

BORDER(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1
Now, redistribution command
BORDER(config-router)#redistribute static metric 10000 100 255 1 1500

Where metric values are:

  • Bandwith – 10000 Kb/s (10 Mb/s);
  • Delay – 100 (tens of microseconds, for 10Mb/s interface we have 1000 microseconds);
  • Reliability – 255 (100% reliable);
  • Loading – 1 (if 255 then 100% loaded);
  • MTU – 1500.
Done! Now, let’s check! On R1 I’ve issued show ip route command and sent a ping to ISP loopback 0 interface
R1#show ip route

... output omitted ...

Gateway of last resort is 192.168.0.3 to network 0.0.0.0

C    192.168.0.0/24 is directly connected, FastEthernet0/0
D*EX 0.0.0.0/0 [170/307200] via 192.168.0.3, 01:45:34, FastEthernet0/0
R1#
R1#ping 192.168.100.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/39/48 ms
R1#

From the output you see that we have a EIGRP route marked as default (D*EX) and a Gateway of last resort set, also ping to ISP’s loopback works fine.

Default route by using ip default-network command

Another method to generate a default route is by using ip default-network command. But first take into account few things:
  • Default network must be reachable by the router that advertise it;
  • All routers that receive default network must know how to reach it through EIGRP.
I chose ISP’s loopback to be default network and on BORDER I set up a static route and then redistributed it into eigrp.
BORDER(config)#ip route 192.168.100.0 255.255.255.0 fastEthernet 0/1
BORDER(config)#router eigrp 1
BORDER(config-router)#redistribute static metric 10000 100 255 1 1500

Now only remains to add ip default-network command on BORDER router and a default route will be generated

BORDER(config)#ip default-network 192.168.100.0

Let’s see the results on R1

R1#show ip route

... output omitted ...

Gateway of last resort is 192.168.0.3 to network 192.168.100.0

C    192.168.0.0/24 is directly connected, FastEthernet0/0
D*EX 192.168.100.0/24 [170/307200] via 192.168.0.3, 00:13:51, FastEthernet0/0
R1#

You have seen from output that a default route is injected into R1’s routing table

Default route with network 0.0.0.0 command

With this method you also need to have a default route on router that generates default route and then use network 0.0.0.0 command, check configurations on BORDER below

BORDER(config)#ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
BORDER(config)#router eigrp 1
BORDER(config-router)#network 0.0.0.0

And now verification on R1

R1#show ip route

... output omitted ...

Gateway of last resort is 192.168.0.3 to network 0.0.0.0

D    10.0.0.0/8 [90/307200] via 192.168.0.3, 00:05:41, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/0
D*   0.0.0.0/0 [90/307200] via 192.168.0.3, 00:05:41, FastEthernet0/0
R1#
R1#ping 192.168.100.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/37/44 ms
R1#

By using ip summary-address command

An alternative method to those described above is to configure a manual summary route on a interface with summary address 0.0.0.0 and mask 0.0.0.0. Then, router will send a default route on that interface.

BORDER(config)#interface fastEthernet 0/0
BORDER(config-if)#ip summary-address eigrp 1 0.0.0.0 0.0.0.0
BORDER(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 0/1
And now the results
R1#show ip route

... output omitted ...

Gateway of last resort is 192.168.0.3 to network 0.0.0.0

C    192.168.0.0/24 is directly connected, FastEthernet0/0
D*   0.0.0.0/0 [90/307200] via 192.168.0.3, 00:00:51, FastEthernet0/0
R1#
R1#ping 192.168.100.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/40/60 ms
R1#
In this lab you have examined how to generate a default route in EIGRP domain, use whichever you like and fits your needs.
 41139 views

Comments (10)

  • Kevrell

    |

    THX that’s a great awnser!

    Reply

  • bincy

    |

    Excellent!

    Reply

  • arun

    |

    Good stuff……….

    Reply

  • Apostolos_Greece

    |

    Awesome tutorial !!!!! The best i have found on the internet!!!

    Reply

  • Dali

    |

    Thanks, easy and clear.

    Reply

  • LEFTERIS

    |

    very helpful….. thanks you

    Reply

  • nazari

    |

    tnx for very nice and simple explanation

    Reply

  • AMIR NEZAM

    |

    The best i have found on the internet!!!

    Reply

  • Rakesh Sharma

    |

    Thanks ……Very clear explanation…

    Reply

  • Zubair Rehman

    |

    I have spent the whole night searching for it and in the end you explained it so easy that it solved my problem.

    Reply

Leave a comment


× 8 = eight