EIGRP route summarization

Written on by admin on. Posted in EIGRP

By default EIGRP has auto summarization enabled. This means that it will summarize to classfull addresses at network boundaries. Leaving auto summarization enabled could cause a lot of troubles in our network. EIGRP has the ability to create summary routes at arbitrary boundaries by using manual summarization. Manual summarization can be applied anywhere in EIGRP domain, on every router, on every interface. Summary route will exist in routing table as long as at least one more specific route will exist. If the last specific route will disappear, summary route also will fade out.

Take note that the metric used by EIGRP manual summary route is the minimum metric of the specific routes

If you want to use autosummarization you have to do nothing because it is enbaled by default, otherwise use no auto-summary  eigrp command to disable it. To do manual summarization go under interface and use ip summary-address eigrp as-number address mask [administrative-distance ] command. Next, you see the topology I’ve used in this lab.

EIGRP-summarization

Unlike OSPF where we can summarize only on ABR or ASBR in EIGRP we can summarize anywhere. I will do this on R2’s S0/0 interface, so a summary route will be sent to R1. First will configure EIGRP to run in this network.

R1

R1(config)#interface serial 0/0
R1(config-if)#ip address 192.168.0.2 255.255.255.0
R1(config-if)#no shutdown

R1(config)#router eigrp 1
R1(config-router)#no auto-summary 
R1(config-router)#network 192.168.0.0

R2

R2(config)#interface serial 0/0
R2(config-if)#ip address 192.168.0.1 255.255.255.0
R2(config-if)#no shutdown 
R2(config-if)#interface fa0/0
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown   
R2(config-if)#interface fa0/1
R2(config-if)#ip address 192.168.8.1 255.255.255.0
R2(config-if)#no shutdown 

R2(config)#router eigrp 1
R2(config-router)#no auto-summary 
R2(config-router)#network 192.168.0.0
R2(config-router)#network 192.168.8.0
R2(config-router)#network 192.168.10.0

R3

R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 192.168.10.2 255.255.255.0
R3(config-if)#no shutdown 
R3(config-if)#interface loopback 0
R3(config-if)#ip address 192.168.11.1 255.255.255.0

R3(config)#router eigrp 1
R3(config-router)#no auto-summary 
R3(config-router)#network 192.168.10.0
R3(config-router)#network 192.168.11.0

R4

R4(config)#interface fastEthernet 0/0
R4(config-if)#ip address 192.168.8.2 255.255.255.0
R4(config-if)#no shutdown 
R4(config-if)#interface loopback 0
R4(config-if)#ip address 192.168.9.1 255.255.255.0

R4(config)#router eigrp 1
R4(config-router)#no auto-summary 
R4(config-router)#network 192.168.8.0
R4(config-router)#network 192.168.9.0

Let’s check now R1’s routing table to see what we’ve got

R1#sh ip route

... output ommited ...

Gateway of last resort is not set

D    192.168.8.0/24 [90/2195456] via 192.168.0.1, 00:00:12, Serial0/0
D    192.168.9.0/24 [90/2323456] via 192.168.0.1, 00:00:12, Serial0/0
D    192.168.10.0/24 [90/2195456] via 192.168.0.1, 00:00:12, Serial0/0
D    192.168.11.0/24 [90/2323456] via 192.168.0.1, 00:00:12, Serial0/0
C    192.168.0.0/24 is directly connected, Serial0/0
R1#

Pay attention to the metrics of learned routes, and after we do summarization, will compare this one with that summary metric. Now I will do summarization on R2’s S0/0 interafce.

R2(config-if)#ip summary-address eigrp 1 192.168.8.0 255.255.248.0

And again will check routing table on R1

R1#sh ip route

... output ommited ...

Gateway of last resort is not set

C    192.168.0.0/24 is directly connected, Serial0/0
D    192.168.8.0/21 [90/2195456] via 192.168.0.1, 00:01:42, Serial0/0
R1#

Do you see? All routes learned from R1 are now summarized and the metric is 2195456, the smallest metric of the specific routes

When you configure an EIGRP summary route, that route will apear on generating router also, but with next hop null0 which is a software interface. Null0 interface is used to prevent packets from being sent further if the router does’nt have a specific route, thus will deny packets to go crazy through the network.
R2#show ip route 

... output ommited ...

Gateway of last resort is not set

C    192.168.8.0/24 is directly connected, FastEthernet0/1
D    192.168.9.0/24 [90/409600] via 192.168.8.2, 01:04:43, FastEthernet0/1
C    192.168.10.0/24 is directly connected, FastEthernet0/0
D    192.168.11.0/24 [90/409600] via 192.168.10.2, 01:04:43, FastEthernet0/0
C    192.168.0.0/24 is directly connected, Serial0/0
D 192.168.8.0/21 is a summary, 00:14:46, Null0
R2#
That’s it! Plan carefully your network and use wisely summarization.
28649 views

You may also like:

Comments (14)

  • Ducky

    |

    Going to put this acrtile to good use now.

    Reply

  • Rado

    |

    Thank you!!!!

    Reply

  • Emma

    |

    Awesome!

    Reply

  • Sagar

    |

    Very helpful.. Thank you..!!

    Reply

  • starcoss

    |

    the lab doesn’t work ? wich image do you use or wich setting ?
    thanks !

    Reply

    • admin

      |

      Hi,
      The image is for 3725 routers. Probably, on your machine it’s in a different location than on mine.

      Reply

  • Net

    |

    The AD should be 5 right? for eigrp summary-route

    Reply

  • darren

    |

    to be more efficient, shouldn’t the summary mask be 255.255.252.0?

    only 4 networks need summarising

    nice document. thanks

    Reply

    • admin

      |

      You are right darren, in this specific case it will be more efficient if you use 255.255.252.0

      Reply

  • Rodrigo

    |

    Great, thanks!

    Reply

  • JOEL OGBECHIE

    |

    I just stumbled on this site. Im currently studying for my CCNP Route. This EIGRP summary is very simplified. Thumbs up to the owner of this blog

    Reply

  • vikrant bhutani

    |

    null0 is for preventing forward plane loops and AS-5 is used to prevent from control plane loops

    Reply

  • Ruwan

    |

    Cheers!!!

    Reply

  • Unknown

    |

    Thanks!!!

    Reply

Leave a comment


+ 5 = thirteen