OSPF internal route summarization

Written on by admin on. Posted in OSPF

OSPF does not support auto summarization, only manual. OSPF route summarization can be of two types:

  1. Internal route summarization;
  2. External route summarization.

 In this article we will work with OSPF internal route summarization on Cisco routers. Unlike EIGRP where is posible to summarize wherever, in OSPF you can do internal route summarization only on ABR (between areas). The reason for this is that Link State Database for all routers in a area must be the same for that area.

Using OSPF summarization give us significant advantages like:

  • Smaller routing tables;
  • Less LSA flooding throughout the network;
  • Less bandwith, memory and CPU resources utilization on network links and devices.

Summary routes are carried by type 3 LSA (called summary LSA). Normally type 3 LSA (which runs between areas) is translated from type 1 LSA and type 2 LSA (which run within area). When summarization is used type 3 LSA joins multiple routes into fewer. So, instead of flooding all type 1 and 2 LSAs (translated into type 3 LSA) between areas, only one or several summary prefixes will be sent between areas carried in type 3 LSA.

By default summary LSA (type 3 LSA), which runs between areas, does not contain summary routes, it contains information from type 1 LSA (Router LSA) and type 2 LSA (Network LSA). So, they carry summarization information after you configure summarization.

To configure OSPF summarization go to ABR under OSPF configuration mode and use this command:

area area-id range address mask [advertise | not-advertise][cost cost]

Check the picture below to see the scenario used in this lab

OSPF internal route summarization

Before we proceed to summarization, first let’s configure OSPF in this network.

ABR

ABR(config)#interface fastEthernet 0/0
ABR(config-if)#ip address 192.168.0.1 255.255.255.0
ABR(config-if)#no shutdown 
ABR(config-if)#interface fastEthernet 0/1
ABR(config-if)#ip address 192.168.1.1 255.255.255.0
ABR(config-if)#no shutdown 
ABR(config-if)#interface serial 0/0
ABR(config-if)#ip address 10.0.0.1 255.255.255.252
ABR(config-if)#no shutdown

ABR(config)#router ospf 1
ABR(config-router)#network 192.168.0.0 0.0.0.255 area 15
ABR(config-router)#network 192.168.1.0 0.0.0.255 area 15
ABR(config-router)#network 10.0.0.0 0.0.0.3 area 0

HQ

HQ(config)#interface serial 0/0
HQ(config-if)#ip address 10.0.0.2 255.255.255.252
HQ(config-if)#no shutdown 

HQ(config)#router ospf 1
HQ(config-router)#network 10.0.0.0 0.0.0.3 area 0

NORTH

NORTH(config)#interface fastEthernet 0/0
NORTH(config-if)#ip address 192.168.0.2 255.255.255.0
NORTH(config-if)#no shutdown

NORTH(config)#router ospf 1
NORTH(config-router)#network 192.168.0.0 0.0.0.255 area 15

SOUTH

SOUTH(config)#interface fastEthernet 0/0
SOUTH(config-if)#ip address 192.168.1.2 255.255.255.0
SOUTH(config-if)#no shutdown 

SOUTH(config)#router ospf 1
SOUTH(config-router)#network 192.168.1.0 0.0.0.255 area 15

I will configure ABR to summarize routes learned in Area 15, thus, a summary route will be sent in Area 0 to HQ. In next output you can see routing table and summary LSAs in link state database on HQ router before we configure summarization.

HQ#show ip route

... output ommited ...

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Serial0/0
O IA 192.168.0.0/24 [110/74] via 10.0.0.1, 00:14:17, Serial0/0
O IA 192.168.1.0/24 [110/74] via 10.0.0.1, 00:14:17, Serial0/0
HQ#
HQ#show ip ospf database

... output ommited ...

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.0.0     192.168.1.1     1004        0x80000001 0x00233B
192.168.1.0     192.168.1.1     1004        0x80000001 0x001845
It’s time to configure summarization. Go to ABR under OSPF configuration and type:
ABR(config-router)#area 15 range 192.168.0.0 255.255.254.0

Range 192.168.0.0/23 contains both networks in Area 15. Let’s verify again routing table and LSDB on HQ to see the results.

HQ#show ip route

... output ommited ...

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Serial0/0
O IA 192.168.0.0/23 [110/74] via 10.0.0.1, 00:04:32, Serial0/0
HQ#show ip ospf database

... output ommited ...

              Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.0.0     192.168.1.1     310         0x80000003 0x001A43

It just works fine. Instead of two summary LSA in database, we have only one, the same is with inter area OSPF routes.

If you have more than one ABR between backbone area and a nonbackbone area, be careful how you configure summarization to avoid suboptimal routing !
In this article we have discussed about how to configure OSPF internal summarization. If you are interested in how to summarize external routes go to OSPF external route summarization lab.
16543 views

Comments (3)

  • Shahkar

    |

    I m using Packet Tracer 16.1 but it doesn’t support area 15 range 192.168.0.0 255.255.254.0 . it doesn’t allow to write range after area # so how can i config this summarization

    Reply

    • admin

      |

      Hi,
      packet tracer does not support this command. Try it in GNS3,
      BR

      Reply

  • Raja

    |

    Awesome and simple. Simply saying : ” PERFECT”

    Theoretically there are many books and urls, but for practicals this is the best.

    I am now perfect on these concepts in both the ways.

    Thank You,

    Raja

    Reply

Leave a comment


six + 6 =