Frame Relay Point to Multipoint

Written on by admin on. Posted in Frame Relay

In this lab we will setup a Frame Relay Point to Multipoint topology on Cisco routers by using GNS3. For routing traffic between devices will use EIGRP routing protocol, we have used 2600 series routers and one frame relay switch. Below is presented the topology. (Watch de video)

 
Frame-Relay Point to Multipoint

Frame-Relay Point to Multipoint Topology

As you have already seen we will configure R1 interface as multipoint but R2 and R3 as point-to-point. Note that by default Split Horizon Rule is in effect on interfaces and EIGRP traffic between R2 Lan and R3 Lan would not be advertisted if we will not disable this rule on R1 S0/0.1 subinterface. To get this working you have to do next configurations:

First we need to configure interfaces, subinterfaces, Frame Relay Encapsulation and Frame Relay mapping for our Routers

R1
interface Loopback0
ip address 192.168.1.1 255.255.255.0 

interface Serial0/0
no ip address
encapsulation frame-relay 

interface Serial0/0.1 multipoint
ip address 192.168.0.1 255.255.255.248
no ip split-horizon eigrp 1
frame-relay map ip 192.168.0.2 102 broadcast
frame-relay map ip 192.168.0.3 103 broadcast
R2
interface Loopback0
ip address 192.168.2.1 255.255.255.0 

interface Serial0/0
no ip address
encapsulation frame-relay 

interface Serial0/0.1 point-to-point
ip address 192.168.0.2 255.255.255.248
frame-relay interface-dlci 201
R3
interface Loopback0
ip address 192.168.3.1 255.255.255.0 

interface Serial0/0
no ip address
encapsulation frame-relay 

interface Serial0/0.1 point-to-point
ip address 192.168.0.3 255.255.255.248
frame-relay interface-dlci 301

Now we can configure EIGRP to route traffic between Routing Devices

R1

router eigrp 1
network 192.168.0.0 0.0.0.7
network 192.168.1.0
no auto-summary

R2

router eigrp 1
network 192.168.0.0 0.0.0.7
network 192.168.2.0
no auto-summary

R3

router eigrp 1
network 192.168.0.0 0.0.0.7
network 192.168.3.0
no auto-summary

Let’s check Routing tables on R2, R3 and to verify ping between R2 and R3

show ip route output

show ip route output

R2 to R3 LAN ping output

R2 to R3 LAN ping output

20169 views

Comments (12)

  • nilanga

    |

    very useful tutorials … plz do continue

    Reply

  • Kevin

    |

    Really helpful. Thank You !

    Reply

  • John

    |

    Thanks. Very helpful. Your entire series is perfect. Please consider making more Youtube videos for all of your posts (with continued good music)…

    Reply

  • Shah Fahad

    |

    In the Topology there is small typing mistake i think.

    Evrywhere is written DLCI to R3…???? what’s this..??
    I think 103 is to R3 and 301 is to R1 and so on

    Reply

    • admin

      |

      Oh, sorry for mistyping guys! Rectified!

      Reply

  • lawangeen

    |

    The topology and the tutorial is very good and working fine.
    If you ping einterfaces that’s working fine but the only one interface on R1 with the IP address “ip address 192.168.0.1 255.255.255.248″ is not working (Pinging) from R1.
    Can some one explain that why the ping from R1 to IP address ip address 192.168.0.1 255.255.255.248 is not working.

    Reply

  • Sami

    |

    @lawangeen
    your post is totally correct.
    I tried to ping R1 serial interface IP. but it does not work!
    I tried even to use Ping 192.168.0.1 source 192.168.1.1 but without success!
    I hope that there is somebody who have a good explanation to that.

    Reply

  • pragash

    |

    After searching every where in the internet…. finally found the solution in this site. thanks so much.

    Reply

  • manoj

    |

    hi i was configure eigrp in multi point frame realy.
    and my topology is bigger. after completed all i got only frame-relay router connected updates not other

    and i used “no ip split-horizon eigrp 100″ but doesn’t iffect

    Reply

  • yellow

    |

    1. Could you have configured R1 and R2 without subinterfaces?
    2. If the broadcast keyword is removed from the maps in R1, will EIGRP create adjacencies?

    Reply

  • Paulo Major

    |

    Hello Dear,

    Thanks for the post, this helped me very much.

    Regards

    Reply

Leave a comment


two + = 6