OSPF Non-Broadcast over Frame Relay

Written on by admin on. Posted in OSPF

In this article you we’ll examine how OSPF is behaving when using it over Frame Relay in a Nonbroadcast IP OSPF Network. Nonbroadcast network type is default on Cisco Routers so you don’t have to set it. Take note that in Nonbroadcast network type DR/BDR election process take place but Dynamic Neighbors Discovery don’t, so we need to add neighbors manually. In next picture you see the topology for this lab.

In topology you will see that Routers connected through Frame Relay are sharing the same subnet 10.0.0.0/29. Besides that each router have a LAN attached to it which is simulated by Loopback interface lo 0.

OSPF non-broadcast network type over Frame Relay

OSPF non-broadcast network type over Frame Relay

In this topology only R1 has PVCs with each Router. In next table is shown DLCI mappings for them.

R1 to DLCI
R2 1002
R3 1003
R4 1004

On R2, R3 and R4 DLCI to R1 is the same: 1001. How I said before, between R2-R3, R3-R4, R2-R4 there is not PVC connection and will not add each other in neighbor list except R1. In turn on R1 will add in neighbor list all Routers. Also we need to add DLCI mappings on FR Switch Like in picture below.

Frame Relay mapping

Frame Relay mapping

Now we’ll configure Routers with DLCI assigned on interfaces and OSPF neighbors manually added. R1
R1(config)#interface loopback 0
R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config)#interface Serial0/0
R1(config-if)#encapsulation frame-relay

R1(config)#interface s0/0.1 multipoint
R1(config-subif)#ip address 10.0.0.1 255.255.255.248
R1(config-subif)#frame-relay interface-dlci 1002
R1(config-fr-dlci)#frame-relay interface-dlci 1003
R1(config-fr-dlci)#frame-relay interface-dlci 1004

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.0.0.0 0.0.0.7 area 0
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#neighbor 10.0.0.4
R1(config-router)#neighbor 10.0.0.3
R1(config-router)#neighbor 10.0.0.2
R2
R2(config)#interface Loopback0
R2(config-if)#ip address 192.168.2.1 255.255.255.0

R2(config)#interface Serial0/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#no shutdown

R2(config)#interface Serial0/0.1 multipoint
R2(config-subif)#ip address 10.0.0.2 255.255.255.248
R2(config-subif)#ip ospf priority 0
R2(config-subif)#frame-relay interface-dlci 1001

R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 10.0.0.0 0.0.0.7 area 0
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
R2(config-router)#neighbor 10.0.0.1
R3
R3(config)#interface Loopback0
R3(config-if)#ip address 192.168.3.1 255.255.255.0

R3(config)#interface Serial0/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#no shutdown

R3(config)#interface Serial0/0.1 multipoint
R3(config-subif)#ip address 10.0.0.3 255.255.255.248
R3(config-subif)#ip ospf priority 0
R3(config-subif)#frame-relay interface-dlci 1001

R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 10.0.0.0 0.0.0.7 area 0
R3(config-router)#network 192.168.3.0 0.0.0.255 area 0
R3(config-router)#neighbor 10.0.0.1
R4
R4(config)#interface Loopback0
R4(config-if)#ip address 192.168.4.1 255.255.255.0

R4(config)#interface Serial0/0
R4(config-if)#encapsulation frame-relay
R4(config-if)#no shutdown

R4(config)#interface Serial0/0.1 multipoint
R4(config-subif)#ip address 10.0.0.4 255.255.255.248
R4(config-subif)#ip ospf priority 0
R4(config-subif)#frame-relay interface-dlci 1001

R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 10.0.0.0 0.0.0.7 area 0
R4(config-router)#network 192.168.4.0 0.0.0.255 area 0
R4(config-router)#neighbor 10.0.0.1

With red we have highlighted OSPF priority configuration, we have done that because we want R1 to be Designated Router. In this topology where all Routers are in the same subnet we need a designated router for this subnet, PVC with all routers has only R1 that’s why we have configured OSPF priority 0 to other routers, with priority 0 Router will not be a DR or BDR (Backup Designated Router). Now it’s time to see the results we got. In next screenshots are shown Neighbors relationships formed, routes learned by R2 and Ping results from R2 to R4.

Neighbors on R1 and R2

Neighbors on R1 and R2

Neighbors on R1 and R2

IP routes on R2

IP routes on R2

Ping Results from R2 to R4

Ping Results from R2 to R4

From the pictures everything is fine except Ping from R2 to R4 loopback interface. If you look in Routing Table you see that next hop to go to 192.168.4.1 is Router R4 (10.0.0.4), but there is no any PVC between these two routers and that’s why ping to R4 failed. If we add Frame Relay mappings on R2, R3 and R4 to each other, ping will work fine. In next configs we added mappings. R2
R2(config)#interface Serial0/0.1 multipoint
R2(config-subif)#frame-relay map ip 10.0.0.3 1001
R2(config-subif)#frame-relay map ip 10.0.0.4 1001
R3
R3(config)#interface Serial0/0.1 multipoint
R3(config-subif)#frame-relay map ip 10.0.0.3 1001
R3(config-subif)#frame-relay map ip 10.0.0.4 1001
R4
R4(config)#interface Serial0/0.1 multipoint
R4(config-subif)#frame-relay map ip 10.0.0.3 1001
R4(config-subif)#frame-relay map ip 10.0.0.4 1001

And now the results:

Ping Results after adding Frame Relay mappings

Ping Results after adding Frame Relay mappings

Results are as expected by using Frame Relay mapping with the same DLCI that goes to R1.

  7700 views

Comments (2)

  • yellow

    |

    Hello.
    Shouldn’t R3 have maps to R2 and R4 and shouldn’t R4 have maps to R2 and R3?

    Reply

  • bluephoenix71

    |

    I believe you can’t configure frame relay map ip on the subif level… only frame-relay interface-dlci is that right?

    Reply

Leave a comment


three + 4 =