OSPF Point to Multipoint Non Broadcast over Frame Relay

Written on by admin on. Posted in Frame Relay, OSPF

This article is a completion of two previously discussed labs where we talked about OSPF multipoint Non-Broadcast over Frame Relay and OSPF Point to Multipoint over Frame Relay. In this lab we will discuss about OSPF Point to Multipoint non-broadcast over Frame Relay, will briefly compare with previously discussed OSPF network types and will build a lab to show how it works.

This OSPF network type behaves like a hybrid between multipoint non-broadcast and point-to-multipoint because DR/BDR election does not happen (multipoint non-broadcast) and Neighbor discovery the same (point to multipoint) which results from ‘nonbroadcast’ keyword in router configuration command. So, if neighbor discovery doesn’t take place we must add them manually under router configuration section.

With these in mind I will start to set up our lab, will use the same topology like in previous articles. In next picture you have the topology.

OSPF over FrameRelay

OSPF Point to Multipoint Non Broadcast over Frame Relay

R1 has Permanent Virtual Circuits (PVC) with all other routers while others have only with R1. In table below you see PVC on R1.

R1 to DLCI
R2 1002
R3 1003
R4 1004

R2, R3 and R4 all have only one PVC to conect to R1. DLCI of this PVC is 1001. R2, R3 and R4 are in the same subnet and to reach each other we’ll add some mappings which will go to R1 as a transit point. Next you see configurations for routers with interfaces, OSPF, PVCs and mappings configured. Highlighted with red are OSPF network type configurations.

R1

R1(config)#interface loopback 0
R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config)#interface Serial0/0
R1(config-if)#encapsulation frame-relay

R1(config)#interface s0/0.1 multipoint
R1(config-subif)#ip address 10.0.0.1 255.255.255.248
R1(config-subif)#ip ospf network point-to-multipoint non-broadcast
R1(config-subif)#frame-relay interface-dlci 1002
R1(config-fr-dlci)#frame-relay interface-dlci 1003
R1(config-fr-dlci)#frame-relay interface-dlci 1004

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.0.0.0 0.0.0.7 area 0
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#neighbor 10.0.0.4
R1(config-router)#neighbor 10.0.0.3
R1(config-router)#neighbor 10.0.0.2

R2

R2(config)#interface Loopback0
R2(config-if)#ip address 192.168.2.1 255.255.255.0

R2(config)#interface Serial0/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#no shutdown

R2(config)#interface Serial0/0.1 multipoint
R2(config-subif)#ip address 10.0.0.2 255.255.255.248
R2(config-subif)#ip ospf network point-to-multipoint non-broadcast
R2(config-subif)#frame-relay map ip 10.0.0.3 1001
R2(config-subif)#frame-relay map ip 10.0.0.4 1001
R2(config-subif)#frame-relay interface-dlci 1001

R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 10.0.0.0 0.0.0.7 area 0
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
R2(config-router)#neighbor 10.0.0.1

R3

R3(config)#interface Loopback0
R3(config-if)#ip address 192.168.3.1 255.255.255.0

R3(config)#interface Serial0/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#no shutdown

R3(config)#interface Serial0/0.1 multipoint
R3(config-subif)#ip address 10.0.0.3 255.255.255.248
R3(config-subif)#ip ospf network point-to-multipoint non-broadcast
R3(config-subif)#frame-relay map ip 10.0.0.2 1001
R3(config-subif)#frame-relay map ip 10.0.0.4 1001
R3(config-subif)#frame-relay interface-dlci 1001

R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 10.0.0.0 0.0.0.7 area 0
R3(config-router)#network 192.168.3.0 0.0.0.255 area 0
R3(config-router)#neighbor 10.0.0.1

R4

R4(config)#interface Loopback0
R4(config-if)#ip address 192.168.4.1 255.255.255.0

R4(config)#interface Serial0/0
R4(config-if)#encapsulation frame-relay
R4(config-if)#no shutdown

R4(config)#interface Serial0/0.1 multipoint
R4(config-subif)#ip address 10.0.0.4 255.255.255.248
R4(config-subif)#ip ospf network point-to-multipoint non-broadcast
R3(config-subif)#frame-relay map ip 10.0.0.2 1001
R3(config-subif)#frame-relay map ip 10.0.0.3 1001
R4(config-subif)#frame-relay interface-dlci 1001

R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 10.0.0.0 0.0.0.7 area 0
R4(config-router)#network 192.168.4.0 0.0.0.255 area 0
R4(config-router)#neighbor 10.0.0.1

Further I will show results of ‘show ip route’ command on R4 and a ping to R3 loopback interface.

IP routes on R4

IP routes on R4

Ping Results from R4 to R3 loopback interface

Ping Results from R4 to R3 loopback interface

10083 views

Comments (2)

  • Klauss Rantes

    |

    I am using Packet Tracer and picked a 2811 as my FR switch. I am trying the same lab above: OSPF Point to Multipoint Non Broadcast over Frame Relay. For some strange reasons, the “ip ospf network point-to-multipoint is not available. can someone help me out there?

    Reply

    • admin

      |

      Packet Tracer does not support all commands, try out to do this in GNS3.

      Reply

Leave a comment


8 + = nine