OSPF Point to Multipoint over Frame Relay

Written on by admin on. Posted in OSPF

In this lab we’ll use the same topology as in the previous one, where we talked about how to configure OSPF on nonbroadcast network type. In Point to Multipoint OSPF behaves opposite to the Non Broadcast network type, namely here OSPF does not elect a DR/BDR but neighbor discovery proccess takes place. So, in this case we shouldn’t add neighbors manually. In topology below you see that interfaces of all routers which communicate through Frame Relay are in the same subnet and each of them has a LAN connected simulated by Loopback interface.

OSPF point to multipoint over FrameRelay

OSPF point to multipoint over FrameRelay

DLCI mappings are the same like in previous article. In table below you see them on R1. R1 has PVC with all routers, but the others have only with R1 and this DLCI is 1001 on all other Routers (R2, R3, R4).

R1 to DLCI
R2 1002
R3 1003
R4 1004

In next listings you see configuration for routers.

R1
R1(config)#interface loopback 0
R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config)#interface Serial0/0
R1(config-if)#encapsulation frame-relay

R1(config)#interface s0/0.1 multipoint
R1(config-subif)#ip address 10.0.0.1 255.255.255.248
R1(config-subif)#ip ospf network point-to-multipoint
R1(config-subif)#frame-relay interface-dlci 1002
R1(config-fr-dlci)#frame-relay interface-dlci 1003
R1(config-fr-dlci)#frame-relay interface-dlci 1004

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.0.0.0 0.0.0.7 area 0
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R2
R2(config)#interface Loopback0
R2(config-if)#ip address 192.168.2.1 255.255.255.0

R2(config)#interface Serial0/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#no shutdown

R2(config)#interface Serial0/0.1 multipoint
R2(config-subif)#ip address 10.0.0.2 255.255.255.248
R2(config-subif)#ip ospf network point-to-multipoint
R2(config-subif)#frame-relay map ip 10.0.0.3 1001
R2(config-subif)#frame-relay map ip 10.0.0.4 1001
R2(config-subif)#frame-relay interface-dlci 1001

R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 10.0.0.0 0.0.0.7 area 0
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
R3
R3(config)#interface Loopback0
R3(config-if)#ip address 192.168.3.1 255.255.255.0

R3(config)#interface Serial0/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#no shutdown

R3(config)#interface Serial0/0.1 multipoint
R3(config-subif)#ip address 10.0.0.3 255.255.255.248
R3(config-subif)#ip ospf network point-to-multipoint
R3(config-subif)#frame-relay map ip 10.0.0.2 1001
R3(config-subif)#frame-relay map ip 10.0.0.4 1001
R3(config-subif)#frame-relay interface-dlci 1001

R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 10.0.0.0 0.0.0.7 area 0
R3(config-router)#network 192.168.3.0 0.0.0.255 area 0
R4
R4(config)#interface Loopback0
R4(config-if)#ip address 192.168.4.1 255.255.255.0

R4(config)#interface Serial0/0
R4(config-if)#encapsulation frame-relay
R4(config-if)#no shutdown

R4(config)#interface Serial0/0.1 multipoint
R4(config-subif)#ip address 10.0.0.4 255.255.255.248
R4(config-subif)#ip ospf network point-to-multipoint
R3(config-subif)#frame-relay map ip 10.0.0.2 1001
R3(config-subif)#frame-relay map ip 10.0.0.3 1001
R4(config-subif)#frame-relay interface-dlci 1001

R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 10.0.0.0 0.0.0.7 area 0
R4(config-router)#network 192.168.4.0 0.0.0.255 area 0

I highlighted with red command where we configure OSPF network type “ip ospf network point-to-multipoint”. You will see in next screenshots that for this kind of OSPF network there is not such a concept like Designated Router or Backup Designated Router.

Neighbors on R1 and R4

Neighbors on R1 and R4

Neighbors on R1 and R4

As you can see in place where should be mentioned DR/BDR or DROTHER there is a dash. Now let’s check if we have routes from R4 to other Routers and we’ll try a ping test.

IP routes on R4

IP routes on R4

Ping Results from R4 to R3

Ping Results from R4 to R3

Everything is fine and ping works well from R4 to R3. This is what we needed to get into this network. Good luck to you!

8880 views

Comments (4)

  • Biswajit Sahoo

    |

    Thanks ……………..Great post.

    Reply

  • Rashad

    |

    This is freaking awesome…. I have been looking all over the internet for examples and this one worked for me the way I needed it to! Thank You!

    Reply

  • Prince Lionel Nzi

    |

    Hi. Thanks for this clear explanation but I got a question.
    I am using Cisco Packet Tracer, and I just have “ip ospf network broadcast” and “ip ospf network point-to-point”. So I have chosen “”ip ospf network broadcast”” and the scenario does not work.
    My question is: Is there a difference between “”ip ospf network point-to-multipoint”” and “ip ospf network broadcast” ?
    if yes, what is the difference?

    Thanks

    Reply

  • portakal

    |

    you rocks!

    Reply

Leave a comment


− 2 = five