OSPF virtual link lab (Scenario 2)

Written on by admin on. Posted in OSPF

Hi there, In previous article (OSPF virtual links lab (Scenario 1)) we discussed about how to connect two parts of a broken Area 0 via virtual link. So, in this article we will discuss about how to connect via virtual link a remote Area (Area 2) to Area 0 which are separated by Area 1.

The way to achieve this is the same like in previous tutorial. Bellow you’ll see the topology for this lab.

OSPF Virtual Link (Scenario 2)

OSPF Virtual Link (Scenario 2)

From the picture you see that R1 belongs to Area 0, R2 to 1, R3 and R4 to 2. OSPF working rules say that every area must be connected to backbone area (Area 0), in this case there is not a physical connection between Area 0 and 2, that’s why we’ll configure a Virtual Link between these two areas. Before we set up Virtual Link in this topology we’ll configure ospf on routers. Below you see the configuration.

R1

R1(config)#interface Loopback0
R1(config-if)# ip address 192.168.0.1 255.255.255.0

R1(config)#interface FastEthernet0/0
R1(config-if)# ip address 10.0.0.2 255.255.255.0

R1(config)#router ospf 1
R1(config-router)# network 10.0.0.0 0.0.0.255 area 1
R1(config-router)# network 192.168.0.0 0.0.0.255 area 0

R2

R2(config)#interface FastEthernet0/0
R2(config-if)# ip address 10.0.0.1 255.255.255.0

R2(config)#interface FastEthernet0/1
R2(config-if)# ip address 10.0.1.1 255.255.255.0

R2(config)#router ospf 1
R2(config-router)#network 10.0.0.0 0.0.0.255 area 1
R2(config-router)#network 10.0.1.0 0.0.0.255 area 1

R3

R3(config)#interface Loopback0
R3(config-if)#ip address 192.168.1.1 255.255.255.0

R3(config)#interface FastEthernet0/0
R3(config-if)#ip address 10.0.2.1 255.255.255.0

R3(config)#interface FastEthernet0/1
R3(config-if)#ip address 10.0.1.2 255.255.255.0

R3(config)#router ospf 1
R3(config-router)# network 10.0.1.0 0.0.0.255 area 1
R3(config-router)# network 10.0.2.0 0.0.0.255 area 2
R3(config-router)# network 192.168.1.0 0.0.0.255 area 2

R4

R4(config)#interface Loopback0
R4(config-if)#ip address 192.168.2.1 255.255.255.0

R4(config)#interface FastEthernet0/0
R4(config-if)#ip address 10.0.2.2 255.255.255.0

R4(config)#router ospf 1
R4(config-router)#network 10.0.2.0 0.0.0.255 area 2
R4(config-router)#network 192.168.2.0 0.0.0.255 area 2

Now there should be neighbor relationships between routers, let’s check if this happened between routers R1 with R2, and R3 with R2, below you can see the results.

Neighbor relationship between R1-R2 and R3-R2

Neighbor relationship between R1-R2 and R3-R2

Neighbor relationship between R1-R2 and R3-R2

Further we’ll configure virtual link on R1 and R3

 R1
R1(config)#router ospf 1
R1(config-router)#area 1 virtual-link 192.168.1.1
R3
R3(config)#router ospf 1
R3(config-router)#area 1 virtual-link 192.168.0.1

Where 192.168.1.1 is Router ID of R3 and 192.168.0.1 is Router ID of R1. So, it remains to check if there are neighbors on this virtual link and to see if R1 has a route to R4.

Neighbors on R1

Neighbors on R1

Routing table on R1

Routing table on R1

In the screenshots above is shown that R1 is neighbor with R3 (R ID 192.168.1.1), and that R1 has route to R4 (highlighted regions).

13965 views

Comments (4)

  • said

    |

    absolutely nice explanation.
    thank youuuuuuuuuuuuuuuu

    Reply

  • Himanshu Saxena

    |

    Thnx sir,

    I have done the same process and I can see route from R1 to R3 in route table.But when I am trying to ping R3 from R1 it’s unsuccessful.Can you plz tell the reason.

    Reply

    • admin

      |

      It should work just fine. Check R3’s routing table to see if there is a route to R1’s network. Also, you can try to do a traceroute from R1 to R3 to find out where it stops.

      Reply

  • Jaspion01

    |

    Great lab.

    Reply

Leave a comment


+ 8 = fourteen