Redistribution into EIGRP

Written on by admin on. Posted in EIGRP

When a network consist of more than one routing protocol, there could be need to advertise routes learned by one routing protocol into another and vice versa. In such a case you may want to take advantage of route redistribution feature. A simple redistribution is quite easy to do. The main configuration command is ‘redistribute’ which is used in EIGRP configuration mode. In this lab I will show you how to do a basic redistribution from OSPF into EIGRP. If you are interested in a tutorial about redistribution EIGRP routes into OSPF take a look at route redistribution into OSPF tutorial. Below you see the network used for this lab. We have one router which runs EIGRP (R3), one runs OSPF (R2), and third (R1) runs both.

Redistribution into EIGRP

Redistribution into EIGRP

At this point I will present configurations on routers with interfaces and routing protocols configured but without redistribution into EIGRP. You can see them further.

R1

R1(config)#interface FastEthernet0/0
R1(config-if)#description to R3
R1(config-if)#ip address 10.0.0.1 255.255.255.0
R1(config-if)#no shutdown

R1(config)#interface FastEthernet0/1
R1(config-if)#description to R2
R1(config-if)#ip address 10.0.1.1 255.255.255.0
R1(config-if)#no shutdown

R1(config)#router eigrp 1
R1(config-router)#network 10.0.0.0 0.0.0.255
R1(config-router)#no auto-summary

R1(config)#router ospf 1
R1(config-router)#network 10.0.1.0 0.0.0.255 area 0
R2
R2(config)#interface Loopback0
R2(config-if)#ip address 192.168.0.1 255.255.255.0

R2(config)#interface Loopback1
R2(config-if)#ip address 192.168.1.1 255.255.255.0

R2(config)#interface FastEthernet0/0
R2(config-if)#description to R1
R2(config-if)#ip address 10.0.1.2 255.255.255.0
R2(config-if)#no shutdown

R2(config)#router ospf 1
R2(config-router)#network 10.0.1.0 0.0.0.255 area 0
R2(config-router)#network 192.168.0.0 0.0.0.255 area 0
R2(config-router)#network 192.168.1.0 0.0.0.255 area 0
R3
R3(config)#interface FastEthernet0/0
R3(config-if)# description to R1
R3(config-if)# ip address 10.0.0.2 255.255.255.0
R3(config-if)#no shutdown

R3(config)#router eigrp 1
R3(config-router)#network 10.0.0.0 0.0.0.255
R3(config-router)#no auto-summary

Now R1 with R3 should be EIGRP neighbors and R1 with R2 OSPF neighbors, check them with show ip eigrp neighbors and show ip ospf neighbor commands.

Now let’s deal with redistribution. To do redistribution from another routing protocol into EIGRP you have to use redistribute command as a router eigrp subcommand. Further there are several options: protocol from which to take routes, it could be Connected, Static, OSPF, EIGRP, ISIS, BGP, RIP. If choose OSPF, further you must type OSPF Process from which to take routes, optional there is match keyword which let you choose routes, external or NSSA external routes to be redistributed. Besides all these you must configure metric values on Router R1: you can set them for all redistributions commands by using default-metric command, for single redistributions command by setting metric under it, and the third method is setting different component metrics to different routes from a route source by using route-map under redistribution command. We will use default-metric and you can see that in next config.

R1
R1(config)#router eigrp 1
R1(config-router)#redistribute ospf 1
R1(config-router)#default-metric 100 10 255 5 1500
R2
R2(config)#ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

I put a default route on R2 to send all unknown traffic R1 thus will get responds to pings that will send from R3. See in next pictures ip routes on R3 and a ping test from R3 to R2.

EIGRP redistributed routes

Routes Redistribution into EIGRP

ping_test

Ping results

From picture you see routes marked with D EX, which means EIGRP external learned routes.

25926 views

Comments (5)

  • hilton

    |

    this guide really works and i appreciate your idea
    thanks.

    Reply

  • vishwanath

    |

    really Its very helpfull for me to understand the topics….

    thank you very muchhhh

    Reply

  • srinivas.g

    |

    sir i have a small doubt …about the loopback interface which u have given on R2 … my question is ? why loopback interface on R2…why not on
    R3…or what happends if we take loopback interfaces on both of the networks …plzzzzzzz sir…give me feedback …to my above email id…

    Reply

  • Ardent

    |

    Nice and to the point. The default-metric statement is the one I was missing to make my redistribution work.

    Thanks

    Reply

  • LEFTERIS

    |

    BRAVOOOOOO!!!!!!!!!!!!!!!!!!

    Reply

Leave a comment


5 × = thirty five